iCloud email delivery issues

Incident Report for M1

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 16:00 CDT

Investigating

A small subset of clients may experience delays or failures receiving MFA emails for iCloud email addresses. We’re working to restore services as soon as possible.
Posted Sep 02, 2025 - 12:46 CDT
This incident affected: Dashboard.