Temporary sign-up error
Incident Report for M1
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 10:06 CDT
Investigating
We’re currently experiencing a temporary issue with new account sign-ups due to an AWS outage. We are monitoring the outage and will update you when it is resolved.
Posted Sep 18, 2023 - 14:13 CDT
This incident affected: Account Signup.