Tax Document Error
Incident Report for M1
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 08:11 CDT
Identified
Our clearing partner, Apex clearing, is currently experiencing an error with their document vendor. You may temporarily not be able to download and view tax documents provided by Apex clearing at this time.

Apex is currently working to correct this issue with their vendor.
Posted Apr 12, 2024 - 16:00 CDT
This incident affected: Statements & Confirms.