"Move Money" button issue

Incident Report for M1

Resolved

This incident has been resolved.
Posted Feb 01, 2024 - 18:11 CST

Identified

Our team has identified an issue with the “Move Money” button. We are working to correct the issue as quickly as possible.
Posted Feb 01, 2024 - 17:26 CST
This incident affected: ACH Transfers.