Statements availability issues

Incident Report for M1

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 21:16 CDT

Investigating

We are currently investigating an issue affecting customer statements. Some users may experience difficulty accessing statements at this time. Our team is actively working to identify the cause and restore full functionality. We apologize for any inconvenience this may cause.
Posted Oct 28, 2025 - 19:57 CDT
This incident affected: Statements & Confirms.