1 Day Performance Issue

Incident Report for M1

Resolved

This incident has been resolved.
Posted Jul 12, 2023 - 11:16 CDT

Identified

We are aware of the issue related to 1 day performance on the platform. Our team is working to resolve this issue. All trading and money movements will proceed as normal despite the performance delay. We appreciate your patience.
Posted Jul 12, 2023 - 10:12 CDT
This incident affected: Performance.