Service Outage
Incident Report for M1
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 17:19 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 13, 2023 - 16:41 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 13, 2023 - 14:45 CDT
Identified
Due to a widespread AWS service outage, we are currently experiencing partial web and app outages. The afternoon trade window was not impacted, but trade activity is not being reflected.

We appreciate your patience while this issue is resolved.
Posted Jun 13, 2023 - 14:28 CDT
This incident affected: Dashboard, Account Signup, and Statements & Confirms.