Trade window delay
Incident Report for M1
Resolved
This incident has been resolved.
Posted Nov 17, 2023 - 10:49 CST
Identified
We are currently experiencing a trade window delay. Our team has identified the issue and we are working to get today’s trades back on track. Thank you for your patience. We will provide another update when trades resume.
Posted Nov 17, 2023 - 09:24 CST
This incident affected: Trading.