Buying power display error
Incident Report for M1
Resolved
Due to a display issue, some clients were seeing a doubled effect of their manual orders on their displayed buying power. This issue has now been corrected.

If you were unable to place a trade due to the buying power display issue, please reach out to us by noon ET by: logging in, clicking “Help” in the lower left corner on Web or tapping "Client Support" on Mobile and selecting "I had an issue with this morning's trade window."

The morning trade window ran as normal for the majority of clients.
Posted Jun 12, 2024 - 09:35 CDT
Identified
Due to a display issue, clients will temporarily see a doubled effect of their manual orders on their buying power. The team is working on a fix and trading will not be impacted.
Posted Jun 12, 2024 - 08:26 CDT
This incident affected: Dashboard.