M1 High-Yield Savings Account July 2023 Interest
Incident Report for M1
Resolved
This incident has been resolved.
Posted Aug 01, 2023 - 16:32 CDT
Identified
Some clients experienced an error regarding their M1 High-Yield Savings Account July 2023 interest calculation. Our team is aware of this and is diligently working to correct it.
Posted Aug 01, 2023 - 08:49 CDT
This incident affected: Spend.