Morning trade window impacted
Incident Report for M1
Resolved
This incident has been resolved.
Posted Jun 11, 2024 - 10:30 CDT
Identified
Some clients were unable to place manual orders for execution during this morning’s trade window. This issue only impacts manual orders. AutoInvest is not impacted. Our team is currently working on a fix and will process orders thereafter. Thank you for your patience.
Posted Jun 11, 2024 - 08:54 CDT
This incident affected: Trading.