Morning Trade Window Delay
Incident Report for M1
Resolved
Trades have resumed after a downtime this morning. We apologize for any inconvenience caused by this delay.
Posted Jul 11, 2023 - 11:03 CDT
Identified
We are currently experiencing a trade window delay. Our team has identified the issue and we are working to get today’s trades back on track. Thank you for your patience. We will provide another update when trades resume.
Posted Jul 11, 2023 - 09:12 CDT
This incident affected: Trading.