Activity tab delay
Incident Report for M1
Resolved
This incident has been resolved.
Posted Oct 03, 2023 - 12:07 CDT
Identified
Our team has identified an issue with the Activity tab not reflecting the trades executed during this morning’s trade window. There was no impact on timing of trades or trade execution. We are working to correct the issue as quickly as possible.
Posted Oct 03, 2023 - 11:56 CDT
This incident affected: Dashboard.