Client Center outage
Incident Report for M1
Resolved
This incident has been resolved.
Posted May 29, 2024 - 11:44 CDT
Identified
Our support tool Intercom has identified an issue causing slowness and errors within our Client Center and Messenger. They are currently investigating the problem and working on a solution.
Posted May 29, 2024 - 11:03 CDT
This incident affected: Help Center.