Partner ACH processor error
Incident Report for M1
Resolved
This incident has been resolved.
Posted Jan 28, 2020 - 10:17 CST
Monitoring
Today (11/29/19) there was an error made by our partner and ACH processor. Some clients will see a second transfer for deposits that initially completed on 11/25. M1 will be reversing these incorrect transfers. This error did not impact trading and no incorrect trading occurred on your account. I sincerely apologize for the confusion and frustration this may have caused.

We understand trust is of the upmost importance when it comes to choosing your financial partners. We take being a steward of your money seriously and we deeply apologize for any loss of trust this error might have caused.

Have a great weekend,

Brian Barnes
Founder & CEO
Posted Nov 29, 2019 - 10:21 CST
This incident affected: ACH Transfers.