Login issues

Incident Report for M1

Identified

The issue has been identified with an upstream system and a fix is being implemented. Service has been partially restored and our team continues to monitor the situation.
Posted Jun 22, 2026 - 09:32 CDT

Investigating

Some clients are experiencing login issues. We’re working to restore services as soon as possible. We’re sorry for the inconvenience and appreciate your patience.
Posted Jun 22, 2026 - 09:09 CDT
This incident affects: Dashboard.