M1 Spend features unavailable
Incident Report for M1
Resolved
This incident has been resolved.
Posted Feb 28, 2022 - 12:34 CST
Identified
Some features of M1 Spend accounts are currently down due to an issue with a third party provider. We are working on a solution and apologize for the inconvenience.
Posted Feb 28, 2022 - 11:02 CST
This incident affected: Spend.