Client Center outage

Incident Report for M1

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 15:24 CST

Update

This incident has been resolved.
Posted Jan 09, 2026 - 15:21 CST

Investigating

Our support tool Intercom has identified an issue causing slowness and errors within our Client Messenger tool. They are currently investigating the problem and working on a solution. In the meantime, please email help@m1.com.
Posted Jan 09, 2026 - 14:29 CST
This incident affected: Help Center.