System outage
Incident Report for M1
Resolved
We experienced a brief outage this afternoon, but our systems are now back up and running. The outage did not have any impact on today's afternoon trade window. Thanks for your patience while we corrected the issue.
Posted Mar 07, 2022 - 15:16 CST
Investigating
Our systems are currently down. Our engineers are working to correct the issue and get our systems back up and running. We apologize for the inconvenience.
Posted Mar 07, 2022 - 14:58 CST
This incident affected: Dashboard.